首页 > mac, php > PHP startup *** Unable to initialize module,These options need to match

PHP startup *** Unable to initialize module,These options need to match

mac 升级到10.10版本之后用phpize 编译第三方类库之后,在启动php的时候报

PHP Warning:  PHP Startup: mongo: Unable to initialize module
Module compiled with module API=20100525
PHP    compiled with module API=20121212
These options need to match
 in Unknown on line 0

是由于扩展编译版本和 PHP 编译版本不符造成

查看/usr/include 是否指向旧版本,如果是,删除include,执行

sudo ln -s /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.10.sdk/usr/include /usr/include

即可

 

分类: mac, php 标签:
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.
*